Using Custom Domain and SSL

Setting a custom URL is a Disha Page Pro feature that allows you to attach your domain name to your already setup Page.

You can set a custom domain for your page, so instead of falz.disha.page you can have falz.com or links.falz.com

Follow the steps below to configure your custom domain.

Step 1

Within your DNS provider’s administration panel, you need to add/edit your (sub)domain to point to Disha and you may use either of the two options below:

  • Using CNAME
    Create a CNAME record with the host as your new subdomain and configure value as your default Disha URL.
    In this example, the host would be links.falz.com and the value would be falz.disha.page.

  • OR Using A Record
    Create an A record with the host as your new subdomain and the value as this IP address 178.128.163.165.
    In this example, the host would be links.falz.com and the value would be 178.128.163.165.

Step 2

Login to your Disha account, and go to Settings, navigate to Custom Domain, type in your custom domain (in the example above, links.falz.com), and then click Set Domain.

We’ll validate your custom domain to ensure you didn’t miss Step 1 above and update your Disha Pages URL.

Your page will instantly be available via your custom domain name.

Setting up Custom Domain with SSL

For Pages that are being published using the default Disha URL (i.e. page-name.disha.page ), no configuration is needed to support https.

For custom domains, we add http:// by default, and because of required domain ownership verification for SSL issuance, we don’t offer https:// for custom domains.

However, you may enable SSL for your custom domain at the DNS level by using a service like Cloudflare.

Log in or create an account with CloudFlare and navigate to your dashboard:

  • Make sure you’ve set up your CloudFlare nameservers
  • Go to the DNS section on the dashboard for your CloudFlare site and create a CNAME record per step 1 above.
  • Now go to Crypto section and make sure SSL is set to Full.
  • Additionally on the same page, enable Always use HTTPS
  • Update your URL in Step 2 to https:// and save.

(Note: if you have the free plan with CloudFlare, it can take up to 24 hours to issue your certificate.)

I have updated my custom domain CNAME… But am still getting error

Hello Nwabueze,
For the custom domain feature to work, you must have brought your domain name from a trusted domain registrar.

Do you have an active domain name?

Yes… I do

Okay, we’re sorry about that. We’ll rectify the issue and get back to you.

Thank you.

I have changed my domain DNS using A name and IP you listed, but when I go to update the domain in the disha pages setting menu I get the message ‘sorry something went wrong please try again’
Can you help please?

Please kindly send your domain name and email address.

Hi Faith, domain is jonblow.com

And my email address is this one

jonnybruce@gmail.com

Hi Jonblow,

We just figured out that you have 2 A record which are values (67.205.12.232 and 178.128.163.165),
Please kindly delete one of 67.205.12.232

hello, I’m getting an error message as well
subdomain: quicklinks.msmetics.com

Hello Msmetics_ng,

Where are you getting the error message from?
Would you be open to share the screenshot of this error message?

hello. I am unable to set my custom domain. I keep getting the error message : Unable to get record, please try again

kindly help.

can you help Dee? i cannot set my custom domain eithe.
Using Custom Domain and SSL

Hello.

I have done the steps above but, I am still getting record not found, I need assistance.
My email is movilbizconsulting@gmail.com
Host spb2020.online

I have been try to set my custom domain but it keeps on showing error
I tried creating an a record it didn’t work
I tried creating a cname record it also didn’t work
My email is popodpo01@gmail.com and i am trying to change to bigsamssub.com.ng

I need help. created a cname and it is telling me record not found. my email is sluminclusion@gmail.com and the domain name is sluminclusion.com

Hello,
I’m trying to change my custom domain url to
links.msmetics.com

but it’s not going
it keeps saying something went wrong

please help

yo tengo un dominio en hostgator, podria usar ese dominio en este sitio? como lo podria hacer en el caso de que se pueda